کشف آسیب‌پذیری خطرناک در کدهای 2011 کوالکوم

حفره امنیتی جدیدی که توسط تیم تحقیقات امنیتی شرکت FireEye کشف شده است، این قابلیت را در اختیار کد ویروسی قرار می دهد که باگ بومی privilege escalation (باگ ترفیع امتیازی) که در رادیوی داخلی کاربر جای گرفته است را اصلاح کند.

کشف آسیب‌پذیری خطرناک در کدهای 2011 کوالکوم

این بدان معنی ست که هکر می تواند به اطلاعات حساس و تنظیمات مهم دستگاه دسترسی پیدا کند. پکیج نرم افزاری کوالکوم از فروم Code Aurora قابل دریافت است و با پروژه سورس باز اندروید ترکیب شده است. کوالکوم این حفره امنیتی را هنگامی معرفی کرد که مجموعه ای از رابط های جدید برنامه کاربری و رابط های اپلیکیشن قابل برنامه نویسی را به عنوان ساختار اضافی اتصال به اینترنت اندروید به ثبت رساند. کوالکوم کد مخرب netd را اصلاح کرده است که در عوض تعدادی از سرویس هایی که در دستگاه های اندرویدی اجرا خواهند شد را اصلاح می کند. این حفره امنیتی به دستور پاکسازی اجازه اجرا می دهد که برای تزریق به کد ویروسی به بخش های حساس دستگاه استفاده می شود. برای مثال این کد ویروسی به تعدادی از مجوزهایی که حتی برای اپلیکیشن های سوم شخص فعال نیستند نیز اجازه دسترسی پیدا می کند. این دسترسی به مجوز باعث می شود که حفره امنیتی بتواند خود را به جای بخش مدیریتی بلوتوث جا بزند، یا تنظیمات APN را تغییر دهد و حتی قفل صفحه را غیر فعال کند. این یعنی اگر دستگاه ها در معرض چنین خطری قرار بگیرند، کاربر نهایی متوجه هیچ مشکلی در دستگاه نخواهد شد.

متاسفانه مشخص نیست که چه تعداد دستگاه اندرویدی ممکن است به این آسیب پذیری خطرناک آلوده شده باشند. بسیاری از تولید کنندگان گوشی های موبایل در دستگاه های خود از کد کوالکوم و یا چیپست کوالکوم استفاه کرده اند. اندروید نان زنجفیلی 2.3 در سال 2011 به بازار عرضه شد و شرکت FireEye تشخیص داده است که این نقص خطرناک حداقل در نسخه های اندروید لالی پاپ و کیت کت و آب نبات ژله ای موجود است. هر بخشی از اندروید که به کد مخرب netd اصلاح شده توسط کوالکوم مجهز باشد، به صورت بالقوه در معرض خطر است. کوالکوم در ژانویه سال 2016، از وجود این مشکل با خبر شد و با همکاری FireEye به دنبال یک راه حل برای رفع آن گشت و در ماه مارس 2016 توانست راه حل آن را پیدا کند.

این پچ نرم افزاری در پچ امنیتی می 2016 گنجانده شده است که مدتی پیش توسط گوگل به کاربران عرضه شد. از نسخه کیت کت 4.4 به بعد، اندروید بهبودهای امنیتی را طوری طراحی کرده که بتواند دسترسی به قسمت های حساس دستگاه را محدود کند و احتمال آسیب های بالقوه را در دستگاه های مورد حمله قرار گرفته کاهش دهد. گوگل اشاره کرد که هیچ کدام از دستگاه های نکسوسی در معرض این آسیب پذیری نبوده اند اما تیم امنیتی FireEye در وبلاگ تخصصی خود توضیح داده است که تولید کنندگان چگونگی عملکرد دستگاه های خود را به صورت جزء به جزء تنظیم می کنند و تشخیص اینکه یک اپلیکیشن ویروسی می تواند چه بلاهایی بر سر دستگاه بیاورد، کار بسیار سختی ست.

جالب است که گوگل به تغییرات اجرا شده در اندروید واکنش نشان داده است، اگرچه چهار ماه طول کشید تا این پچ نرم افزاری به بازار عرضه شود. متاسفانه بعید است که بسیاری از دستگاه های آلوده به این آسیب پذیری بتوانند این پچ امنیتی را دریافت کنند و تا زمانی که این حمله در دستگاه های اندرویدی رایج است، بعید است که تولید کنندگان و اپراتورها مایل باشند دستگاه های قدیمی تر را با به آخرین بروزرسانی های امنیتی تجهیز کنند.

منبع: تک شات

[ منبع این خبر سایت عصر ایران-فناوری می باشد، برای مشاهده متن اصلی خبر می توانید روی این قسمت کلیک کنید ]

برای نمایش تمام اخبار مرتبط با عنوان «کشف آسیب‌پذیری خطرناک در کدهای 2011 کوالکوم» اینجا کلیک کنید. شفاف سازی:
خبر فوق در سایت عصر ایران-فناوری منتشر شده و صرفا در این سایت بازنشر شده است. چنانچه به خبر فوق اعتراض دارید برای حذف آن روی این قسمت کلیک کنید.

نکته: با توجه به جمع آوری خودکار مطالب از سطح وب در صورت مشاهده هرگونه تخلف و یا اخبار غیر مجاز و یا اعتراض به انتشار مطالب سایت ها با ایمیل khabargroup.info@gmail.com در تماس باشید

تبلیغات





جدیدترین اخبار منتشر شده

تبلیغات